mirror of
https://github.com/buckley310/nixos-config.git
synced 2024-11-09 18:47:02 +00:00
20 lines
375 B
Nix
20 lines
375 B
Nix
lib: system:
|
|
|
|
let
|
|
sys = lib.nixosSystem {
|
|
inherit system;
|
|
modules = [
|
|
(
|
|
{ modulesPath, ... }:
|
|
{
|
|
imports = [
|
|
"${modulesPath}/installer/cd-dvd/installation-cd-minimal.nix"
|
|
];
|
|
isoImage.squashfsCompression = "gzip -Xcompression-level 1";
|
|
}
|
|
)
|
|
];
|
|
};
|
|
|
|
in
|
|
sys.config.system.build.isoImage
|