nixos-config/modules/deploy.nix
2023-06-11 14:20:18 -04:00

15 lines
308 B
Nix

{ lib, ... }:
{
options.deploy = {
sshPublicKeys = lib.mkOption {
type = lib.types.listOf lib.types.str;
};
ssh = lib.mkOption {
type = lib.types.attrsOf lib.types.str;
};
tags = lib.mkOption {
type = lib.types.listOf lib.types.str;
default = [ ];
};
};
}